[vistrails-dev] Fwd: Error in VisTrails Server 2.1 on Debian

Matthias Troyer troyer at phys.ethz.ch
Thu Jan 9 11:20:54 EST 2014





> From: Lukas Gamper <gamperl at gmail.com>
> Date: 2014/1/6
> Subject: Error in VisTrails Server 2.1 on Debian
> To: vistrails-dev at sci.utah.edu
> 
> Hi
> 
> There seems to be an error related to Qt in the vistrails_server on Debian:
> 
> QPixmap: Must construct a QApplication before a QPaintDevice
> 
> How to reproduce:
> 
> install a new debian/create a new debian virtual machine
> $> mkdir /server
> $> cd /server/
> $> mkdir vistrails
> $> cd vistrails/
> $> mkdir logs
> $> wget http://downloads.sourceforge.net/project/vistrails/vistrails/v2.1/vistrails-src-2.1-179c82045907.tar.gz
> $> tar -xzf vistrails-src-2.1-179c82045907.tar.gz 
> $> mv vistrails-src-2.1-7fd4888b0ea2 git # make sure the default config works
> $>  cd git/vistrails/
> $> apt-get install zip xvfb
> $> python run.py
> # let vistrails install all needed packages
> $> scripts/start_vistrails_xvfb.sh
> checking if Xvfb is already running...
> ps -eaf | grep /usr/bin/Xvfb | grep :6 | awk '{print $2}'
> Xvfb already running [pid=10982]
> Starting VisTrails in Server Mode on display :6.0 - 
> Vistrails was not running on  http://vis-7.sci.utah.edu:8081
> Vistrails was not running on  http://vis-7.sci.utah.edu:8081
> scripts/start_vistrails_xvfb.sh: line 105: kill: (11020) - No such process
> QPixmap: Must construct a QApplication before a QPaintDevice
> 
> Best
>   Lukas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.vistrails.org/pipermail/vistrails-dev/attachments/20140109/db3d7a9e/attachment.html>


More information about the vistrails-dev mailing list