[vistrails-dev] API problems in VisTrails Server 2.1 on Debian

Tommy Ellqvist tommy.ellqvist at nyu.edu
Thu Jan 23 08:46:23 EST 2014


I see that alps is still using “core.modules” imports. In vistrails 2.1 this should be “vistrails.core.modules”. Can you fix this for the next version of alps? We try to rewrite those imports but it looks like this does not work on the server right now(vistrails.run.fix_paths need to be called). We will fix this for the next release. In the meantime it may be enough to update the imports of core.modules.module_registry.

Thanks,
Tommy Ellqvist
VisTrails Developer

On 23 jan 2014, at 13:59, Lukas Gamper <gamperl at gmail.com> wrote:

> Hi
> 
> Im trying to set up a vistrails 2.1.1 server containing the alps package on a debian machine.
> 
> After downloading vistrails 2.1.1 from vistrails.org and compiling alps, I can start vistrails (using run.py) normally and enable the alps module. The following error occurs, but it seems to work although:
> 
> 2014-01-23 11:19:01,633 CRITICAL:
> /home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348
> Module Tools|MplXYPlotCell in package org.comp-phys.alps (version 2.2.0) is out-of-date.  Please check with the package developer for a new version.
> 2014-01-23 11:19:01,801 CRITICAL:
> /home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348
> Module DataSet|Plot|ShowMplPlot in package org.comp-phys.alps (version 2.2.0) is out-of-date.  Please check with the package developer for a new version.
> 2014-01-23 11:19:02,007 CRITICAL:
> /home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348
> Module DataSet|Plot|ShowListOfPlots in package org.comp-phys.alps (version 2.2.0) is out-of-date.  Please check with the package developer for a new version. 
> 
> If I now start the server (adjusting and running start_vistrails_xvfb.sh) I get the following errors:
> 
> 2014-01-23 13:44:12,546 CRITICAL:
> /home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/packagemanager.py, line 659
> Initialization of package <codepath alps> failed and will be disabled
> Package 'ALPS' failed to initialize because of the following exceptions:
> Traceback (most recent call last):
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py", line 1524, in initialize_package
>     package.initialize()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/package.py", line 450, in initialize
>     self._init_module.initialize()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/init.py", line 185, in initialize
>     dataset.selfRegister()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 95, in selfRegister
>     register(DataSets,'DataSet',abst=True)
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 59, in register
>     reg.add_module(m, namespace=ns, abstract=abst)
> AttributeError: 'NoneType' object has no attribute 'add_module'
> 
> 2014-01-23 13:44:12,546 CRITICAL:
> /home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/packagemanager.py, line 659
> Initialization of package <codepath alps> failed and will be disabled
> Package 'ALPS' failed to initialize because of the following exceptions:
> Traceback (most recent call last):
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py", line 1524, in initialize_package
>     package.initialize()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/package.py", line 450, in initialize
>     self._init_module.initialize()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/init.py", line 185, in initialize
>     dataset.selfRegister()
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 95, in selfRegister
>     register(DataSets,'DataSet',abst=True)
>   File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 59, in register
>     reg.add_module(m, namespace=ns, abstract=abst)
> AttributeError: 'NoneType' object has no attribute 'add_module'
> 
> It seems like core.modules.module_registry.registry is None in the server. Did I miss something?
> 
> btw: there art two versions of the package API documented. Which is prefered?
> http://www.vistrails.org/usersguide/dev/html/packages.html
> http://www.vistrails.org/usersguide/v2.1/html/packages.html
> 
> Best
>   Lukas
> _______________________________________________
> vistrails-dev mailing list
> vistrails-dev at vistrails.org
> http://lists.vistrails.org/mailman/listinfo/vistrails-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.vistrails.org/pipermail/vistrails-dev/attachments/20140123/d3638816/attachment-0001.html>


More information about the vistrails-dev mailing list