[vistrails-dev] VisTrails and downloading files

Juliana Freire juliana.freire at nyu.edu
Thu Oct 26 17:29:51 EDT 2017


BTW, does the workflow below run in your version of VisTrails?
If it does, then I will do the install from source (this is for a talk I
will give tomorrow morning)


For me, it gives several error messages (using the latest Mac binary),
e.g., package ALPS does not use vistrails prefix, package, Package
"org.vistrails.vistrails.vtlcreator" cannot handle upgrade request.
VisTrails will attempt automatic upgrade; UserWarning:  This call to
matplotlib.use() has no effect; Module Tools|MplXYPlotCell in package
org.comp-phys.alps (version 2.2.1) is out-of-date.  Please check with the
package developer for a new version; Module DataSet|Plot|ShowMplPlot in
package org.comp-phys.alps (version 2.2.1) is out-of-date.  Please check
with the package developer for a new version.



Juliana Freire, PhD
Professor, Computer Science & Engineering and Data Science
Executive Director, NYU Moore-Sloan Data Science Environment
New York University
juliana.freire at nyu.edu
(646) 997-4128

Admin: Ann Messinger, Program Operations Manager
      phone: (646) 997-4057, email: am6179 at nyu.edu

On Thu, Oct 26, 2017 at 5:21 PM, Juliana Freire <juliana.freire at nyu.edu>
wrote:

> Do you mean do a git clone and follow all the instructions from
> https://www.vistrails.org/index.php/Mac_Intel_Instructions?
>
> This is too much work... Can't we have an rpz package?
>
>
>
> Juliana Freire, PhD
> Professor, Computer Science & Engineering and Data Science
> Executive Director, NYU Moore-Sloan Data Science Environment
> New York University
> juliana.freire at nyu.edu
> (646) 997-4128
>
> Admin: Ann Messinger, Program Operations Manager
>       phone: (646) 997-4057, email: am6179 at nyu.edu
>
> On Fri, Oct 20, 2017 at 1:21 PM, Rémi Rampin <remi.rampin at nyu.edu> wrote:
>
>> 2017-10-20 10:46 EDT, Juliana Freire <juliana.freire at nyu.edu>:
>>
>>> I have just tried to run VisTrails with a few examples (bike,
>>> terminator) and in both, the download file fails.
>>>
>>> I have downloaded the files manually and replaced downloadfile with file
>>> and it works.
>>>
>>
>> Hi Juliana,
>>
>> Indeed this works fine on my machine, but not when I use the executable.
>> It seems that changes in MacOS have broken the ssl.py module from the time
>> we last released.
>> The error I see when clicking on the "DownloadFile" module > then "Show
>> Error" is:
>>
>> IOError: [Errno 20] Not a directory
>>
>> I'm assuming it is the same for you.
>>
>> Running from a local checkout or using Anaconda should fix this, we
>> should put out a new release with updated versions of those Python modules
>> so that it works on newer Macs. It is surprising that such a prominent
>> feature is broken.
>>
>> Best
>> --
>> Rémi
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.vistrails.org/pipermail/vistrails-dev/attachments/20171026/70ee7925/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ladder_dyl_gap_theta.vtl
Type: application/octet-stream
Size: 42733 bytes
Desc: not available
URL: <https://lists.vistrails.org/pipermail/vistrails-dev/attachments/20171026/70ee7925/attachment-0001.obj>


More information about the vistrails-dev mailing list