<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">2014/1/6 Lukas Gamper</div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">
<font face="courier new, monospace"><div class="im">Starting VisTrails in Server Mode on display :6.0 -<br></div><div class="im">QPixmap: Must construct a QApplication before a QPaintDevice</div></font></blockquote><div><br>
</div><div>Hi Lukas,</div><div><br></div><div>Thanks for spotting this, there is indeed an error with the server initialization code in the new v2.1 release.</div><div><br></div><div>This will be fixed in our next v2.1 release. In the meantime, to get your installation working, you can locate the <font face="courier new, monospace">&#39;application_server.py&#39;</font> file (in <font face="courier new, monospace">vistrails/gui</font>) and replace it with the one attached (or alternatively, you can apply the patch file).</div>
<div><br></div><div>Sorry for the inconvenience</div><div>-- </div><div>Rémi Rampin</div><div>VisTrails developer</div></div></div></div>