<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">I see that alps is still using “core.modules” imports. In vistrails 2.1 this should be “vistrails.core.modules”. Can you fix this for the next version of alps? We try to rewrite those imports but it looks like this does not work on the server right now(vistrails.run.fix_paths need to be called). We will fix this for the next release. In the meantime it may be enough to update the imports of&nbsp;<span class="" style="color: rgb(51, 51, 51); line-height: 15.600000381469727px;">core</span><span class="" style="line-height: 15.600000381469727px; color: rgb(102, 102, 102);">.</span><span class="" style="color: rgb(51, 51, 51); line-height: 15.600000381469727px;">modules</span><span class="" style="line-height: 15.600000381469727px; color: rgb(102, 102, 102);">.</span><span class="" style="color: rgb(51, 51, 51); line-height: 15.600000381469727px;">module_registry.</span><div><div><br></div><div>Thanks,</div><div>Tommy Ellqvist</div><div>VisTrails Developer</div><div><br></div><div>On 23 jan 2014, at 13:59, Lukas Gamper &lt;<a href="mailto:gamperl@gmail.com">gamperl@gmail.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div dir="ltr">Hi<div><br></div><div>Im trying to set up a vistrails 2.1.1 server containing the alps package on a debian machine.</div><div><br></div><div>After downloading vistrails 2.1.1 from <a href="http://vistrails.org/">vistrails.org</a> and compiling alps, I can start vistrails (using run.py) normally and enable the alps module. The following error occurs, but it seems to work&nbsp;although:</div>

<div><br></div><div class="gmail_extra"><div class="gmail_extra">2014-01-23 11:19:01,633 CRITICAL:</div><div class="gmail_extra">/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348</div>

<div class="gmail_extra">Module Tools|MplXYPlotCell in package org.comp-phys.alps (version 2.2.0) is out-of-date. &nbsp;Please check with the package developer for a new version.</div><div class="gmail_extra">2014-01-23 11:19:01,801 CRITICAL:</div>

<div class="gmail_extra">/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348</div><div class="gmail_extra">Module DataSet|Plot|ShowMplPlot in package org.comp-phys.alps (version 2.2.0) is out-of-date. &nbsp;Please check with the package developer for a new version.</div>

<div class="gmail_extra">2014-01-23 11:19:02,007 CRITICAL:</div><div class="gmail_extra">/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py, line 1348</div><div class="gmail_extra">

Module DataSet|Plot|ShowListOfPlots in package org.comp-phys.alps (version 2.2.0) is out-of-date. &nbsp;Please check with the package developer for a new version.&nbsp;</div><div class="gmail_quote"><br></div><div class="gmail_quote">

If I now start the server (adjusting and running start_vistrails_xvfb.sh) I get the following errors:</div><div class="gmail_quote"><br></div><div class="gmail_quote"><div class="gmail_quote">2014-01-23 13:44:12,546 CRITICAL:</div>

<div class="gmail_quote">/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/packagemanager.py, line 659</div><div class="gmail_quote">Initialization of package &lt;codepath alps&gt; failed and will be disabled</div>

<div class="gmail_quote">Package 'ALPS' failed to initialize because of the following exceptions:</div><div class="gmail_quote">Traceback (most recent call last):</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py", line 1524, in initialize_package</div>

<div class="gmail_quote">&nbsp; &nbsp; package.initialize()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/package.py", line 450, in initialize</div>

<div class="gmail_quote">&nbsp; &nbsp; self._init_module.initialize()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/init.py", line 185, in initialize</div>

<div class="gmail_quote">&nbsp; &nbsp; dataset.selfRegister()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 95, in selfRegister</div>

<div class="gmail_quote">&nbsp; &nbsp; register(DataSets,'DataSet',abst=True)</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 59, in register</div>

<div class="gmail_quote">&nbsp; &nbsp; reg.add_module(m, namespace=ns, abstract=abst)</div><div class="gmail_quote">AttributeError: 'NoneType' object has no attribute 'add_module'</div><div class="gmail_quote"><br>
</div>
<div class="gmail_quote">2014-01-23 13:44:12,546 CRITICAL:</div><div class="gmail_quote">/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/packagemanager.py, line 659</div><div class="gmail_quote">
Initialization of package &lt;codepath alps&gt; failed and will be disabled</div>
<div class="gmail_quote">Package 'ALPS' failed to initialize because of the following exceptions:</div><div class="gmail_quote">Traceback (most recent call last):</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/module_registry.py", line 1524, in initialize_package</div>

<div class="gmail_quote">&nbsp; &nbsp; package.initialize()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/core/modules/package.py", line 450, in initialize</div>

<div class="gmail_quote">&nbsp; &nbsp; self._init_module.initialize()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/init.py", line 185, in initialize</div>

<div class="gmail_quote">&nbsp; &nbsp; dataset.selfRegister()</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 95, in selfRegister</div>

<div class="gmail_quote">&nbsp; &nbsp; register(DataSets,'DataSet',abst=True)</div><div class="gmail_quote">&nbsp; File "/home/vt21/vistrails-2.1/vistrails-src-2.1.1-97362185cfd1/vistrails/packages/alps/dataset/__init__.py", line 59, in register</div>

<div class="gmail_quote">&nbsp; &nbsp; reg.add_module(m, namespace=ns, abstract=abst)</div><div class="gmail_quote">AttributeError: 'NoneType' object has no attribute 'add_module'</div><div class="gmail_quote"><br>
</div>
<div class="gmail_quote">It seems like&nbsp;<span class="" style="color:rgb(51,51,51);line-height:15.600000381469727px">core</span><span class="" style="line-height:15.600000381469727px;color:rgb(102,102,102)">.</span><span class="" style="color:rgb(51,51,51);line-height:15.600000381469727px">modules</span><span class="" style="line-height:15.600000381469727px;color:rgb(102,102,102)">.</span><span class="" style="color:rgb(51,51,51);line-height:15.600000381469727px">module_registry</span><span class="" style="line-height:15.600000381469727px;color:rgb(102,102,102)">.</span><span class="" style="color:rgb(51,51,51);line-height:15.600000381469727px">registry is None in the server. Did I miss something?</span></div>

<div class="gmail_quote"><span class="" style="color:rgb(51,51,51);line-height:15.600000381469727px"><br></span></div><div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px">btw: there art two versions of the package API documented. Which is prefered?</span></font></div>

<div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px"><a href="http://www.vistrails.org/usersguide/dev/html/packages.html">http://www.vistrails.org/usersguide/dev/html/packages.html</a></span><br>

</font></div><div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px"><a href="http://www.vistrails.org/usersguide/v2.1/html/packages.html">http://www.vistrails.org/usersguide/v2.1/html/packages.html</a></span><br>

</font></div><div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px"><br></span></font></div><div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px">Best</span></font></div>

<div class="gmail_quote"><font color="#333333"><span style="line-height:15.600000381469727px">&nbsp; Lukas</span></font></div></div></div></div>
_______________________________________________<br>vistrails-dev mailing list<br><a href="mailto:vistrails-dev@vistrails.org">vistrails-dev@vistrails.org</a><br>http://lists.vistrails.org/mailman/listinfo/vistrails-dev<br></blockquote></div><br></body></html>